PCLOS problem sa zvukom (rešeno)

PCLOS problem sa zvukom (rešeno)

offline
  • Pridružio: 02 Avg 2004
  • Poruke: 1673
  • Gde živiš: Kraljevo

Napokon kada sam sastavio novu konfiguraciju i sredio Win 7, došao je na red Linux, ali avaj ne lezi vraže Twisted Evil , sve je proradilo maximalno, osim zvuka. U "traju" stoji ikonica zvučnika i pokazuje da je zvuk na nuli. Kada kliknem na ikonicu zvučnika i otvorim mixer on izgleda ovako:



U Pclos control centru kada otvorim deo gde su hardverske komponente i nameštanje zvuka stoji sledeće:







Takođe i delu za konfiguraciju multimedija stoji ovako:



Manje više dosta toga sam pokušao što sam znao, ali nije dalo nekog rezultata. Inače matična ploča je Gigabyte GA-780T-D3L, a zvučna je Realtek ALC887 codec. Ako neko zna kako, unapred hvala.



Registruj se da bi učestvovao u diskusiji. Registrovanim korisnicima se NE prikazuju reklame unutar poruka.
offline
  • bocke  Male
  • Moderator foruma
  • Glavni moderator Linux foruma
  • Veliki Pingvin
  • Guru
  • Pridružio: 16 Dec 2005
  • Poruke: 12339
  • Gde živiš: Južni pol

Napisano: 10 Nov 2012 16:28

Nisam detaljno pogledao, ali identifikovao sam mogući problem. Tebi je izgleda, umesto zvučne, kao prva ALSA kartica postavljen HDMI ulaz na grafičkoj kartici. U ovom slučaju je potrebno ili izabrati drugu karticu u GUI-u ili zameniti redosled kartica u konfiguracionim datotekama. Za ovo drugo ti ne bih znao reći ovako napamet. Morao bih da se podsetim.

Dopuna: 10 Nov 2012 18:16

Našao. Baci pogled:
http://alsa.opensrc.org/FAQ026



offline
  • Pridružio: 02 Avg 2004
  • Poruke: 1673
  • Gde živiš: Kraljevo

u GUI-u ne može da se promeni, jer druga opcija stoji "unknown"

offline
  • bocke  Male
  • Moderator foruma
  • Glavni moderator Linux foruma
  • Veliki Pingvin
  • Guru
  • Pridružio: 16 Dec 2005
  • Poruke: 12339
  • Gde živiš: Južni pol

Ako se ne snađeš s uputstvom sa Alsa wikija, baci output:
cat /proc/asound/cards
cat /proc/asound/card?/pcm??/info

offline
  • Pridružio: 02 Avg 2004
  • Poruke: 1673
  • Gde živiš: Kraljevo

Napisano: 10 Nov 2012 19:38

Snašao sam se, ali nešto neće da fercera, ili ja samo mislim da sam se snašao Mr. Green
Ovako napravio sam fajl koji "wiki kaže" da treba da se napravi kako bi se zamenila saund card i on izgleda ovako:
/etc/asound.conf
pcm.!default {
    type hw
    card 0
}
ctl.!default {
    type hw           
    card 0
}


e sad ja sam ovo video što ti tražiš, pa sam iz tih informacija napravio ovaj fajl, ali sad ću i tebi da izlistam, tako da vidiš da li greši i gde:

cat /proc/asound/cards
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe024000 irq 16
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfcffc000 irq 19
 2 [Camera         ]: USB-Audio - USB2.0 Camera
                      Etron Technology, Inc. USB2.0 Camera at usb-0000:00:12.2-3, high speed


i

cat /proc/asound/card?/pcm??/info
card: 0
device: 0
subdevice: 0
stream: CAPTURE
id: ALC887-VD Analog
name: ALC887-VD Analog
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1
card: 0
device: 0
subdevice: 0
stream: PLAYBACK
id: ALC887-VD Analog
name: ALC887-VD Analog
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1
card: 0
device: 1
subdevice: 0
stream: CAPTURE
id: ALC887-VD Digital
name: ALC887-VD Digital
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1
card: 0
device: 1
subdevice: 0
stream: PLAYBACK
id: ALC887-VD Digital
name: ALC887-VD Digital
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1
card: 0
device: 2
subdevice: 0
stream: CAPTURE
id: ALC887-VD Analog
name: ALC887-VD Analog
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1
card: 1
device: 3
subdevice: 0
stream: PLAYBACK
id: HDMI 0
name: HDMI 0
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1
card: 1
device: 7
subdevice: 0
stream: PLAYBACK
id: HDMI 1
name: HDMI 1
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1
card: 2
device: 0
subdevice: 0
stream: CAPTURE
id: USB Audio
name: USB Audio
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1


kada sam napravioovaj fajl koji savetuju /etc/asound.conf restartovao sam računar, ali nema nekog efekta, sve isto stoji kao na slikama koje sam ranije postavio.

Dopuna: 10 Nov 2012 20:40

Kad sam umesto brojeva stavio ime kartice, tj. ovako konfigurisao fajl
/etc/asound.conf
pcm.!default {
    type hw
    card HDA ATI SB
}
ctl.!default {
    type hw           
    card HDA ATI SB
}


onda se promeniilo i ovo u PCLOS Control centru, tako da umesto Nvidia sada stoji ovako:



ali u KMixu i dalje stoji Nvidia i izgleda ovako:



i nikako ne mogu da dobijem podešavanja za KMix pomoću kojih bih mogao da pojačam zvuk?!

Dopuna: 11 Nov 2012 10:48

Pokušao sam i sa varijantom da pobrišem sva KMix podešavanja, ali ni to nije upalilo, ili ja nisam dobro uradio, kako god uglavnom sam ovo uradio:
u termnalu sam ubio KMix komandom "killall -9 -- kmix" pa sam onda pobrisao fajlove :
.kde4/share/config/
.kde4/share/apps/kmix/

ali i dalje kada restartujem računar ponovo stoji u kmix-u nvidia kartica i ako je sada u PCLOS kontrol centru Intel HDA driver.
Nakon restarta računara kad ponovo otvorim kmix podešavnja stoji ovo u sledećej putanji
.kde4/share/config/

[MixerALSA::HDA_NVidia:1]
name=

[MixerALSA::HDA_NVidia:1.DevIEC958:0]
is_muted=false
is_recsrc=false
name=IEC958

[MixerALSA::HDA_NVidia:1.DevIEC958:1]
is_muted=false
is_recsrc=false
name=IEC958 2

[MixerALSA::USB2.0_Camera:1]
name=

[MixerALSA::USB2.0_Camera:1.DevMic:0]
is_muted=false
is_recsrc=true
name=Mic
volumeLCapture=0


to je fajl "kmixctlrc"

i u "kmixrc" stoji ovo

[Global]
AllowDocking=true
AutoUseMultimediaKeys=true
ConfigVersion=3
DefaultCardOnStart=ALSA.HDA_NVidia.1.default
Labels=true
MasterMixer=ALSA::HDA_NVidia:1
MasterMixerDevice=IEC958:0
Menubar=true
MixerIgnoreExpression=Modem
Orientation=Vertical
Position=0,0
Size=328,328
Tickmarks=true
TrayVolumeControl=true
Visible=false
VolumeFeedback=false
startkdeRestore=true

[Profiles]
ALSA::HDA_NVidia:1=ALSA.HDA_NVidia.1.default
ALSA::USB2.0_Camera:1=ALSA.USB2.0_Camera.1.default

[View.ALSA.HDA_NVidia.1.default.ALSA::HDA_NVidia:1.IEC958:0]
Show=true
Split=false

[View.ALSA.HDA_NVidia.1.default.ALSA::HDA_NVidia:1.IEC958:1]
Show=true
Split=false

[View.ALSA.USB2.0_Camera.1.default.ALSA::USB2.0_Camera:1.Mic:0]
Show=true
Split=false


čak sam i u ova dva fajla izmeni mesta gde je Nvidia i ubacio na njeno mesto ime katice HDA ATI SB, ali ni to nije pomglo, nakon restarta sve se vratilo na staro.

takođe sam i u .kde4/share/apps/kmix/ pobrisao sva podešavanja i opet nakon restarta pojavili su se sledeći fajlovi:

ALSA.HDA_NVidia.1.default.xml
ALSA.USB2.0_Camera.1.default.xml


sve prepravke sam rado u super user modu i nakon svake sam restartovao računar!

takođe sam i iz linka koji si mi dao za wiki ALSA FAQ odradio poslednju stavku i izmenio

/usr/share/alsa/alsa.conf

kako je opisano tamo, ali ni to nije dalo rezultata.

Nešto stalno "sugeriše" KMix-u da koristi Nvida karticu bez obzira na ove promene, a šta je to, ja više nemam pojma. GUZ - Glavom U Zid Smile

offline
  • bocke  Male
  • Moderator foruma
  • Glavni moderator Linux foruma
  • Veliki Pingvin
  • Guru
  • Pridružio: 16 Dec 2005
  • Poruke: 12339
  • Gde živiš: Južni pol

Koristi li PCLOS Pulseaudio?

offline
  • Pridružio: 02 Avg 2004
  • Poruke: 1673
  • Gde živiš: Kraljevo

Napisano: 11 Nov 2012 13:48

Koristi, ali je po default-u isključen, a i ja ga nisam uključivao pošto nemem potrebe za njim. U gornjem postu ima i slika kako izgleda ta opcija u PCLOS kontrol centru, tj. kako je podešeno kod mene.

Dopuna: 16 Nov 2012 14:15

Posle raznih kombinacija napokon sam došao do rešenja za moj problem! Smile Na forumu PCLOS-a je bilo sličih problema koji su uspešno rešeni kao što je bocke dao link u gornjem postu za Wiki ALSA metodu, ali meni to nije pomoglo?! Rešenje sam našao u instalaciji novog kernela koji je uspešno i odmah prepoznao nove "džidža-midže" Mr. Green koje donosi novi hardver. Zahvalio bih se bocketu na pomoći i sugestijama! Ziveli

offline
  • bocke  Male
  • Moderator foruma
  • Glavni moderator Linux foruma
  • Veliki Pingvin
  • Guru
  • Pridružio: 16 Dec 2005
  • Poruke: 12339
  • Gde živiš: Južni pol

Moram da priznam da sam zaboravio na ovu temu. Elem, drago mi je da sam pomogao da te usmerim na pravu adresu. Wink

Ko je trenutno na forumu
 

Ukupno su 725 korisnika na forumu :: 36 registrovanih, 3 sakrivenih i 686 gosta   ::   [ Administrator ] [ Supermoderator ] [ Moderator ] :: Detaljnije

Najviše korisnika na forumu ikad bilo je 3466 - dana 01 Jun 2021 17:07

Korisnici koji su trenutno na forumu:
Korisnici trenutno na forumu: 4fat, A.R.Chafee.Jr., amonsrb, Apok, Areal84, ArmyBoss, BlackPhantom, celik, cikadeda, Cikela, crnitrn, Djole, DM1994, Dukelander, FOX, goxin, ivan1973, Kaplar2, MB120mm, mercedesamg, Mercury, Milan A. Nikolic, Miskohd, MrNo, ostoja, rodoljub, S-lash, sabros, suton, Toni, vathra, Vlada1389, Vlada78, vlvl, vrlenija, zoranis