Joomla - Infinite loop detected in JError

Joomla - Infinite loop detected in JError

offline
  • juba  Female
  • Zaslužni građanin
  • Pridružio: 04 Jan 2008
  • Poruke: 670
  • Gde živiš: Beograd

Nisam bas neki ekspert, prvi put kacim Joomlu na web i pojavljuje mi se "Infinite loop detected in JError"
Proverila sam configuration.php bar 45 puta i vec dva-tri sata pokusavam na netu da nadjem resenje Sad
Koliko sam uspela da shvatim, uglavnom je problem u
public $dbtype = ''; public $host = ''; public $user = ''; public $password = ''; public $db = '';
i
public $log_path = '/logs'; public $tmp_path = '/tmp';

sta jos moze da bude?
Sta jos da probam da mu uradim pre nego sto spalim kompjuter i sebe zajedno sa njim...?



Registruj se da bi učestvovao u diskusiji. Registrovanim korisnicima se NE prikazuju reklame unutar poruka.
offline
  • Rade Jekić
  • Pridružio: 05 Okt 2005
  • Poruke: 3002
  • Gde živiš: Valjevo

Koja je Joomla u pitanju? 1.7?



offline
  • Pridružio: 02 Sep 2008
  • Poruke: 4092
  • Gde živiš: Bg

Možeš eventualno editovati error.php fajl --> libraries/joomla/error/error.php

1) Edit libraries/joomla/error/error.php
2) Uncomment the line echo debug_print_backtrace(); in throwError function


public static function throwError(&$exception) {    static $thrown = false;    // If thrown is hit again, we've come back to JError in the middle of throwing another JError, so die!    if ($thrown) {       // echo debug_print_backtrace(); // Uncomment this line       jexit(JText::_('JLIB_ERROR_INFINITE_LOOP'));    } . . . }

SRC: Joomla zajednica --> http://forum.joomla.org/viewtopic.php?p=2603760

Takođe predlažu da kontaktiraš svog hosting provajdera, jer je moguće da je problem do njihovog servera.

offline
  • juba  Female
  • Zaslužni građanin
  • Pridružio: 04 Jan 2008
  • Poruke: 670
  • Gde živiš: Beograd

@drummer
Yep - 1.7 je u pitanju

@klodovik
Od svega na linku jedino ovo nisam probala
Citat:For me it worked to find the several occurrences of /var/mysql/mysql.sock in php.ini and change them to /tmp/mysql.sock -- if this seems like a culprit to you, you should probably double check the actual location of your mysql.sock file and edit the path accordingly.Plasim se da nesto ne zeznem ako previse cackam (ne bi bilo prvi put Embarassed )

Hosting je zakupljen kod Euneta, imate li iskustva sa njima?
Na domacem joomla forumu kazu da su ok, pozvacu ih ujutru u svakom slucaju.

offline
  • Pridružio: 02 Sep 2008
  • Poruke: 4092
  • Gde živiš: Bg

Definitivno je problem sa bazom. To se retko dešava u Džumli 1.6, a u ovoj novoj verziji je to koliko vidim vrlo čest problem. Moj savet je da još uvek radiš u Džumli 1.5.23, jednostavno zbog modula i komponenti, x ih ne radi u 1.7 i velika muka je uraditi solidan sajt, ako je nešto "simple" onda ok.

P.S. Možeš da probaš i gore navedeno, samo prethodno uradi bekap tog fajla, pa ako ne bude radilo kako treba, vrati prvobitni.

offline
  • Rade Jekić
  • Pridružio: 05 Okt 2005
  • Poruke: 3002
  • Gde živiš: Valjevo

Slazem se sa kolegom @klodovik-om. Instaliraj poslednju stabilnu 1.5.x verziju jer verzija koju koristis (a i verziju 1.6) jos uvek nije stabilna platforma sa resenim sigurnosnim propustima i jos uvek nema toliko dostupnih modula kao verzija 1.5.

Sto se tice greske koja se pojavljuje...moze da bude veoma tesko pronaci o cemu se radi jer joomla 1.7 svaku gresku karakterise upravo na taj nacin.

Citat:OK, here's what is going on. When Joomla! 1.7 runs across a system error, instead of reporting the error it says "Infinite loop detected in JError". Unless you are a fortune teller, it's virtually impossible to know what the heck is going wrong with your site to debug it.

Izvor Arrow https://www.akeebabackup.com/support/forum/akeeba-.....set/0.html

Najverovatnije da je problem u samom configuration.php fajlu ali kako i sama kazes, pregledala si ga mnogo puta.

Mozda ti nesto odavde bude od pomoci.

offline
  • juba  Female
  • Zaslužni građanin
  • Pridružio: 04 Jan 2008
  • Poruke: 670
  • Gde živiš: Beograd

Samo da se zahvalim svima na trudu.
Sve sam probala, instalaciju 1.5, menjala konfiguracioni fajl... uf, kakav ocaj.
Na kraju sam pozvala eunet i oni su nesto tu resili ali iskreno neznam sta... posle 14-tog poziva bilo me sramota da pitam jos da mi objasnjavaju Embarassed a i oni su se malo namucili. Prvo sto su me pitali je - da li je 1.7 Confused
U svakom slucaju hvala svima jos jednom.

Ko je trenutno na forumu
 

Ukupno su 629 korisnika na forumu :: 6 registrovanih, 1 sakriven i 622 gosta   ::   [ Administrator ] [ Supermoderator ] [ Moderator ] :: Detaljnije

Najviše korisnika na forumu ikad bilo je 3466 - dana 01 Jun 2021 17:07

Korisnici koji su trenutno na forumu:
Korisnici trenutno na forumu: babaroga, cenejac111, cikadeda, Fog of War, Pohovani_00, Roman