Sabayon 4.1 Gnome 64 bita i USB Bluetooth

1

Sabayon 4.1 Gnome 64 bita i USB Bluetooth

offline
  • Uroš Ilić
  • dr stom.
  • Pridružio: 08 Jul 2006
  • Poruke: 2182
  • Gde živiš: Beograd

Ne znam ni kako lepo da predstavim problem. Imam USB Bluetooth, koji kada ga prikljucim, jednostavno ne radi, tj. ne pojavi se cak ni ikona u notification tray.
Gledao sam u Sprtzu i imam instaliran gnome-bluetooth sa svim njegovim potrebnim libovima, tj ako gledam sta mi je jos dostupno od paketa, ima samo kde varijanta, ali uz nju mi vuce jos oko 100Mb paketa kde okruzenja.
Ne mogu da proverim sta se desava buduci da na Sabayonu ne radi komanda lsusb, a pod Mintom, gde mi radi bluetooth, komanda pokazuje
Bus 003 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Ko ima predstavu o cemu se radi, nek mi da smernice i nek trazi, ako treba, dodatne informacije.
Hvala



Registruj se da bi učestvovao u diskusiji. Registrovanim korisnicima se NE prikazuju reklame unutar poruka.
offline
  • pixxel  Male
  • Legendarni građanin
  • Pridružio: 21 Jun 2005
  • Poruke: 9091
  • Gde živiš: Tu i tamo...

probaj ovo:
# emerge net-wireless/bluez-libs net-wireless/bluez-utils net-wireless/bluez-firmware
pa onda
# /etc/init.d/bluetooth start
# hciconfig
Ako ti hciconfig prepozna uredjaj ali pise DOWN, onda treba da editujes /etc/bluetooth/hcid.conf
# HCId options
options {
        # Automatically initialize new devices
        autoinit yes;

        # Security Manager mode
        #   none - Security manager disabled
        #   auto - Use local PIN for incoming connections
        #   user - Always ask user for a PIN
        #
        security auto;

        # Pairing mode
        pairing multi;


        # PIN helper
        pin_helper /etc/bluetooth/pin-helper;
}

# Default settings for HCI devices
device {
        #promeni ime uredjaja kako hoces
        # Local device name
        #   %d - device id
        #   %h - host name
        name "BlueZ at %h (%d)";

        # Local device class
        class 0x3e0100;

        # Inquiry and Page scan
        iscan enable; pscan enable;

        # Default link mode
        lm accept;

        # Default link policy
        lp rswitch,hold,sniff,park;

        # Authentication and Encryption (Security Mode 3)
        #auth enable;
        #encrypt enable;
}

pa onda edituj /etc/bluetooth/pin
12345 (promeni u sta bilo ;) )
I onda
# /etc/init.d/bluetooth restart
# rc-update add bluetooth default


Sve ovo je za gentoo, pa bi trebalo da tera i na sabayonu:
http://www.gentoo.org/doc/en/bluetooth-guide.xml



offline
  • Uroš Ilić
  • dr stom.
  • Pridružio: 08 Jul 2006
  • Poruke: 2182
  • Gde živiš: Beograd

Napisano: 17 Apr 2009 13:55

Hvala pixxel, nasao sam nesto slicno na netu, ali ...
Kad probam, na prvom koraku imam neki dependency hell



Dopuna: 17 Apr 2009 14:13

Shvatio sam da su paketi malo razliciti, pa sa krenuo da trazim imena u konzoli kroz equo i instalirao sve ponudjeno vezano za bluetooth. Onda sam odradio ovo i dobio neke rezultate

offline
  • pixxel  Male
  • Legendarni građanin
  • Pridružio: 21 Jun 2005
  • Poruke: 9091
  • Gde živiš: Tu i tamo...

vidi onda jos da editujes ona dva fajla, ili ih cisto pregledaj, i probaj da l' radi...

offline
  • bocke  Male
  • Moderator foruma
  • Glavni moderator Linux foruma
  • Veliki Pingvin
  • Guru
  • Pridružio: 16 Dec 2005
  • Poruke: 12356
  • Gde živiš: Južni pol

Što se tiče bluetootha, to je već malo komplikovanija priča. Pored blueza biće potrebno da instaliraš dodatne pakete. Nego, čitam nešto na netu. Ne bi li Sabayon trebao da ima podršku za bluetooth "out of the box" (odmah po instalaciji)? Da li si probao da podesiš bluetooth koristeći ikonicu u trayu? Desni klik -> properties. Da li je ta ikonica uopšte aktivna?

offline
  • Uroš Ilić
  • dr stom.
  • Pridružio: 08 Jul 2006
  • Poruke: 2182
  • Gde živiš: Beograd

Nema ikonice, ona dva fajla iz pixxelove reference, uopste ne postoje. Ja sam ih kreirao i pejstovao potrebno, ali to ne vodi nikuda.
Trebao bi Sabayon da podrzava "out of the box" ali eto...
Mislim da sam bas naleteo na bug, ali ne nalazim nikako resenja, prekopao sam net i jos nista. Polako, valjda ce se i to resiti, jedno znam sigurno; Sabayon je stvarno odlicna distribucija i kod mene ce se redovno vrteti nove verzije.

offline
  • bocke  Male
  • Moderator foruma
  • Glavni moderator Linux foruma
  • Veliki Pingvin
  • Guru
  • Pridružio: 16 Dec 2005
  • Poruke: 12356
  • Gde živiš: Južni pol

Hajde da probamo nešto. Digni Sabayon sa Live CDa (ili DVDa) i probaj da li je ikona tu. Ako jeste, pogledaj podešavanja, uključi bluetooth na telefonu (ili nekom drugom BT uređaju) i vidi da li je prepoznat i da li funkcioniše prenos.

offline
  • Uroš Ilić
  • dr stom.
  • Pridružio: 08 Jul 2006
  • Poruke: 2182
  • Gde živiš: Beograd

Vidi, na Live ni nema podrske za bluetooth, tj. nema tih paketa. Ja sam tek po instalaciji potrebnih paketa dobio u System > Preferences ikonu Bluetooth ( ne mogu da je pokrenem) i u Applications > System Tools Bluetooth Analyzer (ni nju ne mogu da pokrenem). U trayu se ne pojavljuje ikona ni kada dignem sistem sa ubodenim blututom, ni kada ga naknadno ukopcam.
Evo, u konzoli pokusaj da pokrenem applikacije za bluetooth

offline
  • Pridružio: 30 Dec 2007
  • Poruke: 4759
  • Gde živiš: Niš

Изгледа да драјвер за hci0 функционише (значи то је ок )
био је неки проблем са dbus-ом недавно ,али на slackware линуксу

нисам сигуран како се манифестује ,вероватно није то
(обично приликом стартовања сервиса не сећам се да ли је јавио грешку
тада)
изгледа као да ови усер-спаце програми јаве грешку?
да ли су добро укомпилирани ?
да није он скинуо,тај менаџер пакета, 32-битне а не 64 битне ?

у суштини може он и из комадне линије да се направи конектовање
али и тада не ради ако је у питању то нешто у вези dbus-а
(немам у ствари уређаје bluetooth али за нека тестирања има фора
са неким виртуелним/емулираним hci уређајем )

offline
  • bocke  Male
  • Moderator foruma
  • Glavni moderator Linux foruma
  • Veliki Pingvin
  • Guru
  • Pridružio: 16 Dec 2005
  • Poruke: 12356
  • Gde živiš: Južni pol

S obzirom da alati daju segmentation fault, pretpostavljam da je instalirao ili pogrešnu verziju ili drajveri nisu dobro kompajlirani. U skladu s tim ni BLUEZ daemon verovatno ne funkcioniše.

Nemam iskustva sa Sabayonom pa ti ne mogu dati konkretan savet, ali pretpostavljam da je mozda problem u podešavanjima make.conf. Pogledaj dokumentaciju u tom smeru i konfiguriši make.conf u skladu sa svojom mašinom.

Ovo je pod uslovom da si koristio emerge za skidanje sors paketa. Ako nisi, to bi bila moja preporuka. Emerge automatski radi kompajliranje i instalaciju tako da oko toga ne treba da brineš.

Ko je trenutno na forumu
 

Ukupno su 698 korisnika na forumu :: 44 registrovanih, 5 sakrivenih i 649 gosta   ::   [ Administrator ] [ Supermoderator ] [ Moderator ] :: Detaljnije

Najviše korisnika na forumu ikad bilo je 3466 - dana 01 Jun 2021 17:07

Korisnici koji su trenutno na forumu:
Korisnici trenutno na forumu: _commandos_, A.R.Chafee.Jr., amaterSRB, Apok, bato, Bobannn90, crnitrn, Cufo, cvrle312, djboj, djo97, dozorni, dragoljub11987, Drug pukovnik, Fog of War, francis begbie, Georgius, goran.vvv, goxin, havoc995, HrcAk47, ikan, krlebgd77, Libertas, ljuba, Mahovljani, Marko Marković, megadeki, Milan A. Nikolic, Mixelotti, mushroom, Neutral-M, operniki, pein, Polemarchoi, S2M, Sass Drake, shaja1, Skywhaler, Sr.Stat., VJ, vlvl, voja64, yrraf