problem sa suse 10.1 i ATI grafičkom

2

problem sa suse 10.1 i ATI grafičkom

offline
  • Emil Beli
  • Pridružio: 03 Jan 2005
  • Poruke: 2990
  • Gde živiš: Beograd

skini RPM ako mozes da nadjes. Obicno neki RPM sadrzi to sto tebi treba.
Evo ti sta se dogadja u praksi, i na to moras da se pripremis
(ovo se meni desilo - lupacu imena, ne mogu da se setim svega)

Failed dependencies libxxxx1.so missing
google -> nasao sam libxYB.rpm
rpm -Uvh libxYB.rpm
Failed dependencies libxxUH.so missing
google -> nasao sam libxxUH.rpm
rpm -Uvh libxxUH.rpm
Failed dependencies xibyyy.so missing
google -> nasao sam xlibxxDB.rpm
rpm -Uvh xlibxxDB.rpm
Failed dependencies ABCD.so missing
google -> nasao sam libABCD.rpm

rpm -Uvh libABCD.rpm
rpm -Uvh xlibxxDB.rpm
rpm -Uvh libxxUH.rpm
rpm -Uvh libxYB.rpm

RADI - potrosheno 2 h i 3 kg zivaca



Registruj se da bi učestvovao u diskusiji. Registrovanim korisnicima se NE prikazuju reklame unutar poruka.
offline
  • Pridružio: 02 Apr 2005
  • Poruke: 1516
  • Gde živiš: # :(){ :|:& };:

thnxx,super ste..

Dopuna: 21 Jun 2006 11:30

iskreno nisam siguran shta treba da skinem u stvari..
suzi trazi libexpat.so.0 a mislim da nigde do sada nisam video taj_file.rpm
samo neki libexpat-devel i slichno..
moze josh malo pomoci?



offline
  • Emil Beli
  • Pridružio: 03 Jan 2005
  • Poruke: 2990
  • Gde živiš: Beograd

Moze, ukucas u google tacno sta ti fali (bez RPM) pa ces videti razno razne linkove, newsgrupe itd.

offline
  • Pridružio: 02 Apr 2005
  • Poruke: 1516
  • Gde živiš: # :(){ :|:& };:

e potrazih tu biblioteku po netu ali naidjoh na ovo..jel odgovara?

RPM resource libexpat.so.0

Provided byexpat-1.95.7-1.1.sh A library for parsing XML shh4 little ndian packages

expat-1.95.5-6.sh3 A library for parsing XML sh3 little endian packages

expat-1.95.5-6.sh4 A library for parsing XML sh4 little endian packages

nigde nisam uspeo da ishcachkam libexpat.so.0 u rpm izdanju pa ako neko vec ima nek pastuje ovde lnk ili neshto sl..
thnxx

Dopuna: 26 Jun 2006 10:52

evo nadjoh upravo http://rpm.pbone.net/index.php3/stat/4/idpl/1621956/com/expat-1.95.8-2.i586.rpm.html
pokushacu sa ovim pa javljam rezultate..Smile

Dopuna: 27 Jun 2006 12:49

ma kakvi,ovo ne radi..
pazite ovo..
pokrenem instalaciju tih "novih" 8.25 driversa..i dobijem poruku da nedostaje libexpat.so.0..
medjutim kada u konzoli otkucam whereis libexpat.so.o
dobijem povratnu poruku da se libexpat.so.1 nalazi na nekoj putanji koje se sada ne secam..
instalirao sam i ove expat biblioteke ali opet isti scenario..nishta se ne deshava..
mislim da cu da odustanem od tih novih drivera..koliko oni mogu bolje da rade od 8.24 bash me zanima..tako da nek ostane za sada na ovome..

offline
  • Emil Beli
  • Pridružio: 03 Jan 2005
  • Poruke: 2990
  • Gde živiš: Beograd

E, nemoguce je da imas ovoliko problema sa glupim drajverom za ATI.

1. idi u YaST i lepo poukljucuj sve DEVEL pakete koje nadjes
2. ponovo probaj

./ati-driver-installer-8.25.18-x86.run --buildpkg SuSE/SUSE101-IA32

rpm -Uhv fglrx_6_9_0_SUSE101-8.25.18-1.i386.rpm

offline
  • bocke  Male
  • Moderator foruma
  • Glavni moderator Linux foruma
  • Veliki Pingvin
  • Guru
  • Pridružio: 16 Dec 2005
  • Poruke: 12315
  • Gde živiš: Južni pol

Da li Suse sigurno nema libexpat u Yastu? Ako nema, našao sam jedan tutorijal na netu. Proveri da li to pomaže.

http://linux.wordpress.com/2006/05/12/suse-101-ati-drivers-installation/

offline
  • Emil Beli
  • Pridružio: 03 Jan 2005
  • Poruke: 2990
  • Gde živiš: Beograd

Ma ja sam to instalirao za 3 min, nije mi jasno kako ima problema sa tim.
Do dushe, prilikom instalacije, odabrao sam i GNome devel pakete, kao i sve devel pakete za koje sam imao njuh da ce trebati.

offline
  • Pridružio: 02 Apr 2005
  • Poruke: 1516
  • Gde živiš: # :(){ :|:& };:

ok,aj da probamo sa tim svim develsima..
kako u yastu da kad pokrenem search za "devel" string i izbaci mi sve pakete koji sadrze taj isti string odaberem sve zajedno a da ne moram da klikcem svaki pojedinachno jer ih ima bash dosta..

i josh jedna stvar dok sam vec ovde..
kako se uninstalliraju paketi instalirani iz source-a?

offline
  • bocke  Male
  • Moderator foruma
  • Glavni moderator Linux foruma
  • Veliki Pingvin
  • Guru
  • Pridružio: 16 Dec 2005
  • Poruke: 12315
  • Gde živiš: Južni pol

purple ::i josh jedna stvar dok sam vec ovde..
kako se uninstalliraju paketi instalirani iz source-a?


Udjes u dir u kome se nalazi source, a zatim otkucas:

make uninstall

Ako to nece, onda tesko... Ili nikako.

Mada postoji jedna varijanta:

Pogledaj izdvojene teme u glavnom "linux forumu", tamo ima i tema o kompajliranju iz sourcea. U njoj se nalazi link ka checkinstall skriptu. Skini ga i instaliraj.

Iskompajliraj program ponovo, a zatim umesto:

make install

Kucas:

checkinstall

Checkinstall ce napraviti nativni paket za tvoj distro (u slucaju Suseija - RPM) i najverovatno ga sam instalirati. Zatim jednostavno deinstaliraj paket iz packet menadzera (Yast). I to je to. Kljucno je da koristis isti source za kompajliranje.

Sta ovo znaci... Imas program instaliran iz sourcea. Sada preko njega instaliras RPM. ali taj rpm paket sadrzi istovetne fajlove tako da se postojeci prepisuju. Zatim ga izbrises pomocu Yasta i time uklanjas ceo paket.

E, sad... Jedno 80% programa sasvim lepo radi sa checkinstall skriptom. Ali i dalje ima tih 15-20% koji ce biti manje-vise problematicni.

offline
  • Pridružio: 02 Apr 2005
  • Poruke: 1516
  • Gde živiš: # :(){ :|:& };:

instalirah ja te sve develse beli ali opet ista spika..
odoh do ctrl+f1
su
pass
cd /home/purple/Desktop
init 3
ls
ati-blablabla
chmod +x ./ati-blablabla
./ati-blablabla --buildpkg SuSE/SUSE101-IA32
napravi on meni rpm
ali kad dodje do rpm -Uvh ili -ivh samo:
libexpat.so.0 missing..
i dovidjenjce sa tim driverom..nece da se instalira..

Ko je trenutno na forumu
 

Ukupno su 673 korisnika na forumu :: 35 registrovanih, 6 sakrivenih i 632 gosta   ::   [ Administrator ] [ Supermoderator ] [ Moderator ] :: Detaljnije

Najviše korisnika na forumu ikad bilo je 3028 - dana 22 Nov 2019 07:47

Korisnici koji su trenutno na forumu:
Korisnici trenutno na forumu: _Rade, A.R.Chafee.Jr., aljosa7, amaterSRB, Apok, Arhiv, Bane san, Bojan5150, celik, Cirkon, dac, danilopu, djboj, dragonserbia, Drug pukovnik, Duh sa sekirom, HrcAk47, ibrahimiemina27, ikan, Ilija Grubor, kovinacc, Logic005, Markoni29, Milan A. Nikolic, mrav pesadinac, MrNo, nenad81, perko91, Recce, Ruski Sremac, Sirius, Toni, trajkoni018, VJ, živorad srejić