Opet problem sa pen drajvom - pomoc

Opet problem sa pen drajvom - pomoc

offline
  • Emil Beli
  • Pridružio: 03 Jan 2005
  • Poruke: 2990
  • Gde živiš: Beograd

Kad prikljucim pen drive, izgleda kao da nije u mogucnosti da kreira direktorijum, tj da mountuje u /media

U cemu gresim? Svaka pomoc dobrodosla.

(pen drive je na /dev/sda1 )

fstab

/dev/hdc4            /                    reiserfs   acl,user_xattr        1 1
/dev/hda1            /windows/C           vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/hdc1            /windows/E           vfat       defaults                             1 2
/dev/hda5            /windows/D           ntfs       ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdc5            /windows/F           ntfs       ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdc6            /windows/G           ntfs       ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdc7            /windows/H           ntfs       ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdc8            /home                reiserfs   acl,user_xattr                       1 2
/dev/hdc3            swap                 swap       defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/dvdrecorder     /media/dvdrecorder   subfs      noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0             /media/floppy        subfs      noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0
none                 /subdomain       subdomainfs noauto         0 0
/dev/sda1            /media/sda1/         usbfs      rw,users 0 0


mtab:

/dev/hdc4 / reiserfs rw,acl,user_xattr 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
tmpfs /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/hda1 /windows/C vfat rw,noexec,nosuid,nodev,gid=100,umask=0002,utf8=true 0 0
/dev/hdc1 /windows/E vfat rw 0 0
/dev/hda5 /windows/D ntfs ro,noexec,nosuid,nodev,gid=100,umask=0002,nls=utf8 0 0
/dev/hdc5 /windows/F ntfs ro,noexec,nosuid,nodev,gid=100,umask=0002,nls=utf8 0 0
/dev/hdc6 /windows/G ntfs ro,noexec,nosuid,nodev,gid=100,umask=0002,nls=utf8 0 0
/dev/hdc7 /windows/H ntfs ro,noexec,nosuid,nodev,gid=100,umask=0002,nls=utf8 0 0
/dev/hdc8 /home reiserfs rw,acl,user_xattr 0 0
usbfs /proc/bus/usb usbfs rw 0 0



Registruj se da bi učestvovao u diskusiji. Registrovanim korisnicima se NE prikazuju reklame unutar poruka.
offline
  • Pridružio: 10 Avg 2005
  • Poruke: 151
  • Gde živiš: Novi Sad

Prvo, stavi da pen drive ima fajl sistem (vfat).

Evo fstab linije koja radi savršeno:

/dev/sda1       /mnt/plejer             vfat    noauto,users,umask=000 0 0



offline
  • Pridružio: 26 Avg 2005
  • Poruke: 384
  • Gde živiš: Beograd

El imas napravljen direktorijum /media/sda1/ ako nemas napraviga. i ubaci onu gore liniju za fstab i moralo bi da ti radi.

offline
  • Pridružio: 10 Avg 2005
  • Poruke: 151
  • Gde živiš: Novi Sad

Da, /media/sda1/ mora da postoji!

offline
  • bocke  Male
  • Moderator foruma
  • Glavni moderator Linux foruma
  • Veliki Pingvin
  • Guru
  • Pridružio: 16 Dec 2005
  • Poruke: 12315
  • Gde živiš: Južni pol

Koliko se ja sećam, u Suziju postoji deamon koji detektuje novi umetnuti hardver koji je stalno pokrenut u KDE/Gnome oblasti za notifikaciju (tray). Ranije je bilo problema sa USB flash memorijom. Fora je u tome što taj deamon nastoji da automatski montira USB flash čim se umetne u računar. A u tome (bar ranije) nije uspevao. Inače pri umetanju je kreriao neki direktorijum ala USB-nesto-nesto (u /media)...

Pošto već dugo, dugo, dugo nisam dirao SuSE, ne bih mogao tačno da ti kažem šta i kako. Ali bar kod Suze se to zna: Yast. Ako ne koristiš Yast postoji mogućnost da Suzijevi startup skriptovi obrišu sva podešavanja koja si napravio ručno.

Dopuna: 24 Mar 2006 23:38

BTW, ljudi su u pravu da dir /mnt/sda1 mora postojati, samo ja mislim da Suzijev deamon to pokušava dinamički da uradi (briše i kreira po potrebi). A kada ne uspe onda frka.

Ok... Moja iskustva se zasnivaju na Suse 9.2. Možda je to ispravljeno u 10.0. Ne znam. Batalio sam Suse pre godinu dana.

offline
  • Emil Beli
  • Pridružio: 03 Jan 2005
  • Poruke: 2990
  • Gde živiš: Beograd

Ne ono sa fstabom nije pomoglo. Suse izgleda hoce sam da kreira folder u media i onda nastane problem (device busy or already mounted).

@Bocke
Da, u pitanju je tacno to. Probrljao sam po yastu i nashao da ga on sam setuje. Moze to i da se iskljuci, ali sam pogledao manual, treba par stvarchica da se ukljuci u kernelu.
Medjutim, mislim da mi je taj daemon puko onda kad mi je puko suse zbog nekog update-a.
Sad cu da prekompajliram kernel pa cu da javim.

Ko je trenutno na forumu
 

Ukupno su 933 korisnika na forumu :: 57 registrovanih, 8 sakrivenih i 868 gosta   ::   [ Administrator ] [ Supermoderator ] [ Moderator ] :: Detaljnije

Najviše korisnika na forumu ikad bilo je 3028 - dana 22 Nov 2019 07:47

Korisnici koji su trenutno na forumu:
Korisnici trenutno na forumu: 4channer, _commandos_, _Sale, A.R.Chafee.Jr., aljosa7, amaterSRB, Apok, branko7, BSD, carpbuster, cezar 35, cikadeda, danilopu, Dannyboy, dehhhhi, DENIRO, djboj, draganca, dule10savic, Faki-Valjevo, Georgius, h8propaganda, havoc995, Hektor, HrcAk47, ivica976, Kibice, Kruger, KS, kybonacci, leptirleptir, magna86, manda87, MB120mm, Mercury, Miskohd, novator, nuke92, pedja.st, pera12345, piton, Profica, Regrut Boskica, repac, royst33, sekretar, Skywhaler, Snorks, Srki94, stegonosa, vladetije, voja64, VP6919, zexoni, zillbg, zlatkovuka, |_MeD_|