Problemi sa montiranjem particija u Ubuntuu 9.10

1

Problemi sa montiranjem particija u Ubuntuu 9.10

offline
  • Brok  Male
  • Moderator foruma
  • Mihajlo Bogdanović
  • Linux driver - fighter - warrior
  • Pridružio: 04 Maj 2005
  • Poruke: 3197
  • Gde živiš: U autu i ispred računara, Kraljevo

"Moj" tradicionalni problem. Još malo će da izađe nova verzija Ubuntua a ja još nisam ni montirao particije kako treba. Embarassed

Guglao sam, tražio, probao svašta, pa upropasto fstab te ga pomoću live Ubuntu vratio, i u jednom momentu čak i rešio pitanje montiranja particija ali problem se opet "vratio".

Postavio sam pitanje na srpskoj Ubuntu zajednici i jedan momak (Zika) mi je pomogao da sredim montiranje particija. Da ne bih sada prepisivao sve šta je tamo pisano, nadam se da se uredništvo MC-a neće ljutiti, postaviču link ka toj temi sa Ubuntu zajedinice (tamo mi je korisničko ime Broker):
http://www.ubuntu-rs.org/forum/viewthread.php?tid=9597#pid112850

Meni je najbitnije da su mi montirane particije sda5 i sda6.
Sda6 je montirana i radi kako treba, ali sda5 je isto montirana ali je po botovanju nema na desktopu i ako je bez lozinke ulazim i vidim njen sadržaj, ali ni po ulasku u nju ona se ne pojavljuje na desktopu.

Sda7 je montirana ali mi ona i nije toliko bitna, na njoj je W7, dok na sda1 je XP i ona nije montirana (a i ne mora da bude).

Još jedna stvar mi je jako bitna za prticije sda5 i sda6, da imam ro pristup. Da se ne petljam sa rw pristupom pošto sam čitao da nije baš "zdravo" da se obični odnosno neiskusni korisnici koriste taj pristup NTFS particijama.

Sadašnje stanje etc/fstaba:

# /etc/fstab: static file system information.
#
#  -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda8 :
UUID=190d4c0b-63f4-4956-98e1-a3b190655f91 / ext4 errors=remount-ro 0 1
# Entry for /dev/sda9 :
UUID=0fc660da-8e62-4400-aa63-c1900f9058a0 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sda7 /media/Lokal/042Disk ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/sda6 /media/Hard/041disk ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/sda5 /media/Hard/040disk ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/sdb1 /media/sdb1 vfat defaults 0 0

i

broker@broker-desktop:~$ sudo blkid
/dev/sda1: UUID="C064393264392C92" TYPE="ntfs"
/dev/sda5: UUID="14306EFB306EE2EA" LABEL="Hard disk" TYPE="ntfs"
/dev/sda6: UUID="1C50782C50780F30" LABEL="Hard disk" TYPE="ntfs"
/dev/sda7: UUID="3A4802E348029DAF" LABEL="Lokal Disk" TYPE="ntfs"
/dev/sda8: UUID="190d4c0b-63f4-4956-98e1-a3b190655f91" TYPE="ext4"
/dev/sda9: UUID="0fc660da-8e62-4400-aa63-c1900f9058a0" TYPE="swap"
broker@broker-desktop:~$



Registruj se da bi učestvovao u diskusiji. Registrovanim korisnicima se NE prikazuju reklame unutar poruka.
offline
  • Rogi  Male
  • Mod u pemziji
  • Najbolji košarkaš koji
  • je ikada igrao ovu igru
  • Pridružio: 31 Avg 2005
  • Poruke: 11687

Na dno /etc/fstab dodaj:

# /dev/sd(xy)
/dev/sd(xy) /media/sd(xy) ntfs defaults,umask=007,gid=46 0 1
# /dev/sd(mn)
/dev/sd(mn) /media/sd(mn) ntfs defaults,umask=007,gid=46 0 1

gde ces naravno ono sd(xy) i sd(mn) zameniti za tacne oznake particija, recimo sda1 i sda2 (proveri koje su pomocu gparteda, recimo)

Onda:

sudo mkdir /media/sd(xy)
sudo mkdir /media/sd(mn)



vazi isto za sd(xy) i sd(mn)

Posle toga:

sudo mount -a


Ako nije problem, daj mi sliku iz gparted-a

sudo gparted



offline
  • Brok  Male
  • Moderator foruma
  • Mihajlo Bogdanović
  • Linux driver - fighter - warrior
  • Pridružio: 04 Maj 2005
  • Poruke: 3197
  • Gde živiš: U autu i ispred računara, Kraljevo

Zašto bi bio problem:

offline
  • Rogi  Male
  • Mod u pemziji
  • Najbolji košarkaš koji
  • je ikada igrao ovu igru
  • Pridružio: 31 Avg 2005
  • Poruke: 11687

Idemo ovako:

Prvi korak, dodaj ovo u f-stab.

# /dev/sda1
/dev/sda1 /media/sda1 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda5
/dev/sda5 /media/sda5 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda6
/dev/sda6 /media/sda6 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda7
/dev/sda7 /media/sda7 ntfs defaults,umask=007,gid=46 0 1



Komanda za f-stab sudo gedit /etc/fstab

Sacuvas promene.

Drugi korak, kucas svaki posebno u terminal


Citat:sudo mkdir /media/sda1

sudo mkdir /media/sda5

sudo mkdir /media/sda6

sudo mkdir /media/sda7


Treci korak, kucas ovo u terminalu


sudo mount -a


Cetvrti korak, restart.

offline
  • Brok  Male
  • Moderator foruma
  • Mihajlo Bogdanović
  • Linux driver - fighter - warrior
  • Pridružio: 04 Maj 2005
  • Poruke: 3197
  • Gde živiš: U autu i ispred računara, Kraljevo

Znaš gde sam se prešao, ja sam samo dodao linije koje si mi ispisao ali one postojeće nisam obrisao te sam sada dobio ovo:



Verovatno samo treba da obrišem u fstabu sve staro pod sda1, 5, 6 i 7?

A sa sd5 opet se javlja isti problem, otvaram je, ne traži mi lozinku, ali se ona ne pojavljuje na radnoj površini.
I sada je montirana i sd1 particija što ranije nije bila.

Jel unosom ovih linija u fstabu imam ro pristup particijama?

offline
  • Pridružio: 16 Nov 2007
  • Poruke: 277
  • Gde živiš: Republika Srpska

ja sam montiranje diskova riješio sa programom koji automount-uje NTFS diskove:
Na tek upaljen komp, tj. NTFS diskovi ne smiju biti vec mountovani:
kod:

sudo aptitude update
sudo aptitude install ntfs-config

Nakon toga naci program NTFS configuration tool u Applications > System Tools ili System > Administration i cekirati opcije

offline
  • Brok  Male
  • Moderator foruma
  • Mihajlo Bogdanović
  • Linux driver - fighter - warrior
  • Pridružio: 04 Maj 2005
  • Poruke: 3197
  • Gde živiš: U autu i ispred računara, Kraljevo

Znam da particije nisu i da ne treba da budu montirane odmah po difoltu, i odmah sam i probao da ih montiram sa NTFS Configuration Tool-som ali nažalost ništa od te rabote. Embarassed

offline
  • Uroš Ilić
  • dr stom.
  • Pridružio: 08 Jul 2006
  • Poruke: 2182
  • Gde živiš: Beograd

Evo jedan koristan link
http://www.tuxfiles.org/linuxhelp/fstab.html

offline
  • Pridružio: 02 Sep 2008
  • Poruke: 4092
  • Gde živiš: Bg

Taxista ::Znam da particije nisu i da ne treba da budu montirane odmah po difoltu, i odmah sam i probao da ih montiram sa NTFS Configuration Tool-som ali nažalost ništa od te rabote. Embarassed

Verovatno dobiješ neku grešku, napiši je ovde ili okači ss?

-----------------------
Možeš i da instaliraš Storage device Manager:
sudo apt-get install pysdm
Kucaj pysdm kao root --> u prozoru koji se pojavi pronađi NTFS particiju --> na desnoj strani prozora imaš dugme "Mount", klikni ga. To je sve, od sledećeg boot - a sve je auto.

Evo još par linkova, možda pomogne:

- https://help.ubuntu.com/community/MountingWindowsPartitions/ThirdPartyNTFS3G
- http://www.shareconnector.com/howto-remember-authe.....910-karmic - ovo je možda najlakši način. Smile

offline
  • Brok  Male
  • Moderator foruma
  • Mihajlo Bogdanović
  • Linux driver - fighter - warrior
  • Pridružio: 04 Maj 2005
  • Poruke: 3197
  • Gde živiš: U autu i ispred računara, Kraljevo

Pokušaću, ali posle toliko pokušaja (jednom sam fstab skroz uništio te nisam mogao da podignem sistem) plašim se da se to ponovo ne dogodi.

Sve je meni ovo jasno i ništa mi nije jasno, tako otprilike stoje stvari. Very Happy

Pobrisao sam linije u fstabu od ranije a ostavio one koji mi je Rogi dao i sada nemam sda5 particiju na radnoj, mada je otvaram bez lozinke.
I nisam još proverio da li imam ro pristup.

A fstab je sada ovog sadržaja:


# /etc/fstab: static file system information.
#
#  -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda8 :
UUID=190d4c0b-63f4-4956-98e1-a3b190655f91 / ext4 errors=remount-ro 0 1
# Entry for /dev/sda9 :
UUID=0fc660da-8e62-4400-aa63-c1900f9058a0 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sda1 /media/sda1 ntfs-3g defaults,locale=en_US.UTF-8 0 1
/dev/sda5 /media/sda5 ntfs-3g defaults,locale=en_US.UTF-8 0 1
/dev/sda6 /media/sda6 ntfs-3g defaults,locale=en_US.UTF-8 0 1
/dev/sda7 /media/sda7 ntfs-3g defaults,locale=en_US.UTF-8 0 1


I još jedna stvar mi nije jasna, ranije je Bocke pominjao da kod svake moderne distribucije mora da se ubace i UUID-ovi za svaku praticiju, ne razumem zašto je sada to nepotrebno. Question

Ne ne daje mi nikakvu grešku, osim gore opisane sda5 particije.
Probaću.

Imam ga već instaliranog i evo šta kaže za sda5:

Ko je trenutno na forumu
 

Ukupno su 740 korisnika na forumu :: 37 registrovanih, 6 sakrivenih i 697 gosta   ::   [ Administrator ] [ Supermoderator ] [ Moderator ] :: Detaljnije

Najviše korisnika na forumu ikad bilo je 3466 - dana 01 Jun 2021 17:07

Korisnici koji su trenutno na forumu:
Korisnici trenutno na forumu: _Sale, babaroga, black_arrow, bojank, Boris90, Brankoni, cenejac111, danilopu, Georgius, goran.babic5, goxin, havoc995, helen1, ibssa, ikan, janezek67, Jovan Nenad, kolateralnasteta, Konda, krlebgd77, Milan A. Nikolic, miodrag, moldway, ofbeyond, RJ, sakota79, Singidunumac, Snorks, sombrero, sovanova95, ssekir75, Tas011, Toni, VJ, Vlad000, vlvl, yufighter