Qt kompajliranje

1

Qt kompajliranje

offline
  • Saša Stojanović
  • Pridružio: 27 Dec 2005
  • Poruke: 118
  • Gde živiš: Beograd

Zadnjih pet programa nisam uspeo da instaliram iz source-a jer za vreme konfiguracije mi se pojavi ovo:
''checking for Qt... configure: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!''
Kako da rešim ovaj problem? Inače, ovu qt-mt biblioteku sam našao baš tamo gde bi trebala da bude ali je ipak ne vide skripte za konfiguraciju.



Registruj se da bi učestvovao u diskusiji. Registrovanim korisnicima se NE prikazuju reklame unutar poruka.
offline
  • Pridružio: 04 Sep 2003
  • Poruke: 24135
  • Gde živiš: Wien

Jel odgovara verzija (>= Qt 3.0) ?



offline
  • gamzzy 
  • Legendarni građanin
  • Pridružio: 24 Apr 2003
  • Poruke: 10725
  • Gde živiš: Novi Sad

Vrlo je moguće da nemaš instalirane *-devel pakete za qt3

offline
  • bocke  Male
  • Moderator foruma
  • Glavni moderator Linux foruma
  • Veliki Pingvin
  • Guru
  • Pridružio: 16 Dec 2005
  • Poruke: 12351
  • Gde živiš: Južni pol

Koji je distro u pitanju? Proveri u Package Manageru da li je istaliran qt3-devel paket. Ako ne, u vecini distribucija (sem *buntu familije) se nalazi na instalacionim diskovima. Ukoliko je u pitanju *buntu, skini pomocu Synaptica.

offline
  • Saša Stojanović
  • Pridružio: 27 Dec 2005
  • Poruke: 118
  • Gde živiš: Beograd

Mandriva je u pitanju. Instaliran je qt3-devel. Tačnije libqt3-devel-3.3.4-24

offline
  • Pridružio: 01 Okt 2004
  • Poruke: 351
  • Gde živiš: Qrshumliya

Mozda malo glupo pitanje: Procitao li INSTALL, README ili tako nesto.
Mozda je potrebno uraditi rucno neki `qmake` or someting...

offline
  • Pridružio: 23 Mar 2004
  • Poruke: 523

Gdje ti se nalaze Qt biblioteke? Ako su negdje van standardnih puteva za biblioteke moraš izmijeniti /etc/ld.so.conf i nakon toga odraditi ldconfig.
Nakon toga, trebalo bi da svi programi mogu da nađu Qt biblioteke.

offline
  • Saša Stojanović
  • Pridružio: 27 Dec 2005
  • Poruke: 118
  • Gde živiš: Beograd

Uradio sam i ldconfig ali situacija ostaje ista. Uopšte mi nije jasno kako su se instalirali predhodni programi iz source-a, a sad ovi neće!?

offline
  • Pridružio: 29 Sep 2005
  • Poruke: 316
  • Gde živiš: ZR

jesi li probao da nađeš libqt-mt-devel ???

Ili može biti problem ako je qt kompajliran bez -thread ocije, onda napravi libqt.so.

Probaj na napraviš link libqt-mt.so na libqt.so

Ono mt znači multithread.. Smile

offline
  • Pridružio: 03 Jan 2006
  • Poruke: 137
  • Gde živiš: Agartha

fino ti pise da moras da instalira qt-mt

ako i to imas instalirano probaj prvo da ukucas $ export QTPATH=/putanja/do/qt/source-a pa onda ./configure Smile

prethodni programi su ti se instalirali normalno vjerovatno zbog toga sto nijesu zahtjevali source od Qt-a Smile

Dopuna: 28 Sep 2006 12:52

ili probaj da pokrenes
./configure --with-qtdir=QTDIR (umjesto ovoga QTDIR putanju do source-a Qta). Ako ne bude to radilo vidi ./configure --help tamo bi trebalo da pise koji je switch za postavljanjje QTDIR-a

Ko je trenutno na forumu
 

Ukupno su 1003 korisnika na forumu :: 49 registrovanih, 13 sakrivenih i 941 gosta   ::   [ Administrator ] [ Supermoderator ] [ Moderator ] :: Detaljnije

Najviše korisnika na forumu ikad bilo je 3466 - dana 01 Jun 2021 17:07

Korisnici koji su trenutno na forumu:
Korisnici trenutno na forumu: _Sale, A.R.Chafee.Jr., Apok, aramis s, Bane san, cikadeda, Ctrl x, dac, dane007, DARKMEN22, darkstar101, dekao, gorantrojka, goxin, ILGromovnik, Insan, komkom, Krusarac, kybonacci, Leonardo, LepizLoca, madza, manda87, mane123, MB120mm, Mercury, miodrag, Misirac, mnn2, moldway, Morocco, mrvica78, nenad81, NoOneEver Dreams, operniki, piston79, Polemarchoi, raketaš, Recce, RJ, robertino, Srky Boy, suton, theNedjeljko, VJ, vlvl, vranjanac29, vukdra, zajcev1