Sta je glib?

1

Sta je glib?

offline
  • Pridružio: 18 Apr 2003
  • Poruke: 342

checking for GLIB - version >= 2.0.3... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: "Cannot find glib"


sta moze da bude to???
koji paket treba da mu instaliram?



Registruj se da bi učestvovao u diskusiji. Registrovanim korisnicima se NE prikazuju reklame unutar poruka.
offline
  • Goran 
  • Prof.Mr.Dr.Sci. Traumatologije
  • Pridružio: 05 Maj 2003
  • Poruke: 9977
  • Gde živiš: Singidunum

Ja nađoh gomilu nekih sajtova sa tom problematikom.
http://www.google.com/search?sourceid=navclient&am.....+2%2E0%2E3



offline
  • Pridružio: 18 Apr 2003
  • Poruke: 342

pa dobro znam ja sta je to otprilike... ali nece i ako imam sve instalirano sto mi treba za kompiliranje programa...

ali mislio sam ne bi bilo lose da se i na ovom forumu resi problem... tj da neko napise o cemu se radi...

ipak Hvala, na google linku ali ne pomaze... Sad

offline
  • Pridružio: 18 Apr 2003
  • Poruke: 746

glib je biblioteka koja je potrebna GTK+ biblioteci. Sto ce reci prvo kompajliras ili instaliras odredjenu verziju glib-a i posle odredjenu verziju GKT+...

Neki programi jednostavno traze odredjenu noviju ili stariju verziju glib-a i gtk-a od one koju ti imas.

offline
  • Pridružio: 18 Apr 2003
  • Poruke: 342

ovako skinem najnoviju verziju glib2.2 ako se ne varam.
raspakujem ukucam ./config
kaze mi gettext mi treba
ok skinem gettext raspakujem kucam configure,
gettext mi kaze imam staru verziju pkg-config odem instaliram pkg-config najnoviju verziju, pa instaliram i gettext! i onda srecan odem instaliram glib tj. configure i install!

e onda odem u onaj program sa koga sam u prvom postu pastovao gresku (xchat2.0.5) i kucam configure i on izbaci sledece... stvarno ne znam sta da radim!


*** 'pkg-config --modversion glib-2.0' returned 2.2.2, but GLIB (2.0.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: "Cannot find glib"

offline
  • Pridružio: 18 Apr 2003
  • Poruke: 746

a da... oce to sa tim pkg-configom... ima neki fajl koji se nalazi u pkg-conf direktorijumu (tako nekako) koji kaze koja je verzija biblioteke i sl. Elem, to je sve RH-ova ili GNOME izmisljotina, a moguce je da kada kompajliras svoj glib on taj novi fajl stavi u /usr/local/.... umesto u /usr

Ja sam se tako zezao sa mozillom i nisam uspeo nish da uradim.

offline
  • Pridružio: 18 Apr 2003
  • Poruke: 342

nista onda nego naviko sam na xchat....
ajd uzecu kvirc ili ksirc... :-)

offline
  • AxeZ 
  • Legendarni građanin
  • Pridružio: 17 Apr 2003
  • Poruke: 3989
  • Gde živiš: Novi Sad, Vojvodina

Cek, sto kompajliras, samo skini rpm...Smile
koji distro?

offline
  • gamzzy 
  • Legendarni građanin
  • Pridružio: 24 Apr 2003
  • Poruke: 10725
  • Gde živiš: Novi Sad

Mislim da se hvalio da koristi Debian...

offline
  • Pridružio: 18 Apr 2003
  • Poruke: 342

hvalio sam debian mislis :-)

jeste debian distribucija
ali mislim da moze rpm pomocu "alien" programa da se pretvori u .deb

jer moze tako ili postoji drugi nacin?

Ko je trenutno na forumu
 

Ukupno su 559 korisnika na forumu :: 5 registrovanih, 2 sakrivenih i 552 gosta   ::   [ Administrator ] [ Supermoderator ] [ Moderator ] :: Detaljnije

Najviše korisnika na forumu ikad bilo je 3466 - dana 01 Jun 2021 17:07

Korisnici koji su trenutno na forumu:
Korisnici trenutno na forumu: A.R.Chafee.Jr., Brot, LUDI, nik8282, trajkoni018