XP+Slackware

1

XP+Slackware

offline
  • Pridružio: 06 Apr 2005
  • Poruke: 403
  • Gde živiš: Beograd

Imam dva hard diska.
Na primarnom mi je instaliran Windows XP a na sekundarnom hocu da stavim Linux i da oba budu upotrebljiva.
E tu nastaje problem jer ne umem da to napravim.
Pokusavao sam to pomocu Partition magic-a ali nikako da se digne Linux.
Pretpostavljam da je negde problem oko konfiguracije LILO-a.

Bio bih zahvalan za neko objasnjenje postupka koji zelim da uradim.



Registruj se da bi učestvovao u diskusiji. Registrovanim korisnicima se NE prikazuju reklame unutar poruka.
offline
  • NtC  Male
  • Ugledni građanin
  • Pridružio: 18 Mar 2004
  • Poruke: 457
  • Gde živiš: Novi Sad

Malo si nejasno napisao, jel ti Linux vec instaliran ili nije?



offline
  • Pridružio: 06 Apr 2005
  • Poruke: 403
  • Gde živiš: Beograd

Pa ja sam ga instalirao na brugom disku ali ne mogu da ga dignem dok XP radi.
Da,koristio sam Boot Magic za odabir ali kada odaberem Linux ne digne se nista.

Ako neko moze da mi opise ceo postupak u nekoliko recenica bilo bi super jer negde opasno gresim a nisam svestan toga :]

Dopuna: 17 Okt 2005 18:34

Kada kazem da XP radi mislim da mogu da ga dignem.

offline
  • Emil Beli
  • Pridružio: 03 Jan 2005
  • Poruke: 2990
  • Gde živiš: Beograd

offline
  • Pridružio: 09 Okt 2005
  • Poruke: 99
  • Gde živiš: Nis, Serbia

Pa dobro, covek je sigurno mislio da bira prilikom boota masine.
Kako si instalirao LILO? U MBR ili nesto drugo? Probaj da boot-ujes Slack sa instalacionog diska pa da proveris konfiguraciju za LILO.

offline
  • Pridružio: 06 Apr 2005
  • Poruke: 403
  • Gde živiš: Beograd

Naravno da i ne zelim da ga dignem dok XP radi vec da biram na pocetku ili XP ili Slackware.
Problem je u konfiguraciji LILO-a,to neznam da odradim.
Ako ga stavim u MBR na prvom disku mislim da cu onda obrisati NT Loader i necu moci da dignem ni XP.

Koliko sam ja shvatio treba da konfigurisem NT Loader (menjajuci boot.ini) da pri odabiru Slackware-a pokrene LILO koji ce da digne Slackware posto NT loader sam to ne moze.E tu nastaje problem.

Vase ideje?

offline
  • Pridružio: 09 Okt 2005
  • Poruke: 99
  • Gde živiš: Nis, Serbia

centaur ::Naravno da i ne zelim da ga dignem dok XP radi vec da biram na pocetku ili XP ili Slackware.
Problem je u konfiguraciji LILO-a,to neznam da odradim.
Ako ga stavim u MBR na prvom disku mislim da cu onda obrisati NT Loader i necu moci da dignem ni XP.

Koliko sam ja shvatio treba da konfigurisem NT Loader (menjajuci boot.ini) da pri odabiru Slackware-a pokrene LILO koji ce da digne Slackware posto NT loader sam to ne moze.E tu nastaje problem.

Vase ideje?

Pazi, ja sam uvek ubacivao LILO u MBR jer je to najbolje resenje. LILO ce onda da pozove NT Loader jer mu je to zadataka. Dakle, bootuj Slack sa instalacionog diska. Kad podignes ono sto imas na drugom disku kucaj
man lilo.conf
Tu ces naci uputstvo kako da podesis korektno lilo.conf. Posle toga ga izedituj i snimi u MBR diska koji je podesen u BIOS-u kao prvi boot. I to je to. U svakom slucaju, ako zeznes loader za WinXP procedura oporavka je jednostavna. Pokrenes instalaciju za WinXP sa cd-a. U prvom meniju biras repair konzolu. Uneses admin pass i izvrsis dve komande: fixmbr i fixboot i resio si boot za win :D.

offline
  • Pridružio: 20 Apr 2003
  • Poruke: 2416
  • Gde živiš: NS

stavi lilo slobodno u mbr. posle samo dodas par linija i moci ces da boot-ujes xp.

nesto ovako:

other = /dev/hda1
label = WinXP

nek neko proveri ko ima win, mislim da je ovako. ili napravi boot disketu za linux, a mozes i pomocu instalacionog cd-a da dizes sistem. ubacis cd i ispisace ti uputstvo
boot bare.i noinitrd ro /dev/hda1

hda1 zameni sa odgovarajucim, zavisno gde ti se nalazi root particija.

primari master hda (prva particija hda1, druga hda2...)
secondary master hdb
itd.

offline
  • Dark 
  • Zaslužni građanin
  • Pridružio: 03 Dec 2003
  • Poruke: 677
  • Gde živiš: Beograd

Nema potrebe da ruchno editujesh lilo.conf kad postoji konfiguracioni utility koji kreira lilo.conf
Boot-ujes slackware sa prvim cdom i ulogujesh se kao root.

Kad si se ulogovao kao root kucash:

mount

pa pogledash na kom uredjaju ti je root filesystem (/) i dali je mount-ovan ro ili rw. To mozhesh komandom mount. Kod mene to izgleda ovako i kod mene je uredjaj /dev/hda6 :

root@office:/home/dark# mount
/dev/hda6 on / type ext2 (rw)

pa onda

mount / -o remount,rw (u slucaju da je ro)

pa konfigurises lilo komandom

liloconfig

Idesh na expert config, start lilo configuration with new lilo header, kazhesh da hocesh na MBR, kazhesh koji je uredjaj (iz gornje komande si video), odredish vreme, ime za taj os (tipa linux ili neshto ali mora biti jedna rech, bez razmaka) i josh dodash eventualno windows particiju ako je imash. Kad zavrshish sa konfiguracijom potrebno je da ukucash samo lilo da bi upucao loader u MBR..

offline
  • Pridružio: 06 Apr 2005
  • Poruke: 403
  • Gde živiš: Beograd

Sada kada sam to zahvaljujuci vama resio. Deluje strasno prosto a dugo vremena sam se mlatio sa time.

Osnovna greska kod mene je bila to sto sam LILO stavljao u MBR na drugom disku koji nije bio bootabilan (nisam bio siguran sta ce se desiti ako ga stavim na prvi koji je bootabilan i na kome se nalazi XP).
Koristeci Dark-ove instrukcije problem je resen.

HVALA

PS Sada treba podesiti modem.

Ko je trenutno na forumu
 

Ukupno su 617 korisnika na forumu :: 34 registrovanih, 4 sakrivenih i 579 gosta   ::   [ Administrator ] [ Supermoderator ] [ Moderator ] :: Detaljnije

Najviše korisnika na forumu ikad bilo je 3466 - dana 01 Jun 2021 17:07

Korisnici koji su trenutno na forumu:
Korisnici trenutno na forumu: A.R.Chafee.Jr., amaterSRB, bojanM84, celik, danilopu, darkangel, darkstar101, Dorcolac, Faki-Valjevo, havoc995, HrcAk47, jednoruki krstivoje, Jester, konstruktor, kovinacc, Krusarac, KS, kybonacci, Libertas, Miskohd, mnn2, Nebo_M, Oluj2.1, ruger357, samsung, tanakadzo, tomigun, Toni, USSVoyager, vathra, virked, Vlada1389, xJeremijAx, yufighter