apt-get

apt-get

offline
  • Peca  Male
  • Glavni Administrator
  • Predrag Damnjanović
  • SysAdmin i programer
  • Pridružio: 17 Apr 2003
  • Poruke: 23184
  • Gde živiš: Niš

Kada pokrenem apt-get upgrade, dobijem sledece:
Citat:$ apt-get upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages have been kept back:
bind9-host clamav clamav-base clamav-freshclam dnsutils exim expect gnupg gs imagemagick libbit-vector-perl libclamav1 libmime-perl
libtiff-tools lilo mutt php4-cgi php4-imap php4-pear squirrelmail vim


Sta znaci ovo "The following packages have been kept back" ?
Njih preskace?
Zasto?
Gde se to podesava, sta da preskoci?

Mogu li igde da vidim listu svih paketa, o kojima apt-get vodi racuna?

p.s. u pitanju je Debian 3.1



Registruj se da bi učestvovao u diskusiji. Registrovanim korisnicima se NE prikazuju reklame unutar poruka.
offline
  • bocke  Male
  • Moderator foruma
  • Glavni moderator Linux foruma
  • Veliki Pingvin
  • Guru
  • Pridružio: 16 Dec 2005
  • Poruke: 12341
  • Gde živiš: Južni pol

Ovo nađoh na netu:

Citat:From /usr/doc/apt/users-guide.txt.gz

4.2.4. The Kept Back list
-------------------------

The following packages have been kept back
compface man-db tetex-base msql libpaper svgalib1
gs snmp arena lynx xpat2 groff xscreensaver

Whenever the whole system is being upgraded there is the possibility
that new versions of packages cannot be installed because they require
new things or conflict with already installed things.
In this case the
package will appear in the Kept Back list. The best way to convince
packages listed there to install is with `apt-get install' or by using
`dselect' to resolve their problems.


Nadam se da će ti pomoći. Poz. Wink



offline
  • Peca  Male
  • Glavni Administrator
  • Predrag Damnjanović
  • SysAdmin i programer
  • Pridružio: 17 Apr 2003
  • Poruke: 23184
  • Gde živiš: Niš

To bas i ne pije vodu, ja ih normalno instaliram kad im navedem ime:
apt-get install bind9-host
i on se normalno instalira Confused

offline
  • Pridružio: 05 Jun 2003
  • Poruke: 2075
  • Gde živiš: MaYur CitY

To se desava usled konflikata izmedju starijih verzija depsa i novih.
tako da deb te pakete ne upgrade kako bi radili normalno.
Najbolje uradi apt-get install tog programa kog zelis .
Probaj sa dselect d vidis najlakse sve zavisnosti paketa i sl.
Konflikte itd ili preko aptitude

offline
  • Peca  Male
  • Glavni Administrator
  • Predrag Damnjanović
  • SysAdmin i programer
  • Pridružio: 17 Apr 2003
  • Poruke: 23184
  • Gde živiš: Niš

Jasno.
Hvala Smile

offline
  • bocke  Male
  • Moderator foruma
  • Glavni moderator Linux foruma
  • Veliki Pingvin
  • Guru
  • Pridružio: 16 Dec 2005
  • Poruke: 12341
  • Gde živiš: Južni pol

Peca ::To bas i ne pije vodu, ja ih normalno instaliram kad im navedem ime:
apt-get install bind9-host
i on se normalno instalira Confused


Upravo to ti i piše:

Citat: The best way to convince
packages listed there to install is with `apt-get install' or by using
`dselect' to resolve their problems.


Tj. Ne možeš ih instalirati pomoću apt-get upgrade, već jedino pomoću apt-get install. Zašto i kako... Verovatno se pitaš zar onda apt-get install ne bi isto stvorio konflikte? Pravo da ti kažem ne znam... Verovatno je u pitanju način kako apt instalira paket u jednom, a kako u drugom slučaju. Najbolje je (ako te zanima) da pogledaš Debianovu dokumentaciju.

Recimo... Možda baš /usr/doc/apt/users-guide.txt.gz koji je pomenut gore.

A Blood je lepo objasnio o čemu se radi:
Citat:To se desava usled konflikata izmedju starijih verzija depsa i novih.
tako da deb te pakete ne upgrade kako bi radili normalno.

offline
  • Peca  Male
  • Glavni Administrator
  • Predrag Damnjanović
  • SysAdmin i programer
  • Pridružio: 17 Apr 2003
  • Poruke: 23184
  • Gde živiš: Niš

E sad, sledece pitanje.
Koliko je pametno drzati daemone koje apt-get instalira i upgrade-uje.

U pitanju je Debian 3.1.
Primecujem da svakog dana izlaze update-ovi za razne pakete, sto znaci da odrzavaju to.
Ipak, ne furaju najnovije verzije... recimo drze Apache 1.3.33, a izasao je 1.3.36, koriste jos bind8, a izasao je bind9, itd...
Verovatno su ovo verzije koje nemaju propust (apache od 1.3.33 ispravlja sve neke gluposti), i stabilne su [kao cela apache 1.3.x serija], ali opet, da cujem vasa misljenja...

Da li se osloniti na ono sto apt-get 'odrzava' ?

Govorim o masini koja je server, gde je security bitan...

offline
  • Emil Beli
  • Pridružio: 03 Jan 2005
  • Poruke: 2990
  • Gde živiš: Beograd

Kolko sam ja upucen, Deb namerno ne updateuje verzije jer je njegov glavni adut stabilnost. Deb ne pada, cak ni kad updateujes pakete, sto se za ostale distroe ne moze reci.

offline
  • Pridružio: 05 Jun 2003
  • Poruke: 2075
  • Gde živiš: MaYur CitY

Zato sto debian ima poseban pogled na stabilnost i sigurnost paketa.
Vecinom su sve stable verzije starije u odnosu na trenute na trzistu.
Apache imas paket apache2.
Pazi imas dva izbora:

--Drzati SVe stable apt-get ovane stvari ali sve kako nebi bilo
sukoba sa onima koje si instalirao iz source-a

--instalirati sve najnovije verzije iz izvora , patchovati rucno i apgrejdovati

Sada vidi koje ti je bolje. ja preferiram broj 1.
Sem npr sto prekompajliram ssh zbog versiona i sl gluposti.

Ako zelis sigurnost mani se linuxa i predji na openbsd Smile
Trenutno ga izucavam i mogu reci da je to totalni novi nivo kontrole
sto se tice sigurnosti.

A sto se tice debiana sledi sledece:
-2.6 kernel
-grsec
-chrootovani servisi
-tls/ssl gde god je moguce

Naravno o ovome se moze tutorial napisati Smile

Ko je trenutno na forumu
 

Ukupno su 650 korisnika na forumu :: 30 registrovanih, 2 sakrivenih i 618 gosta   ::   [ Administrator ] [ Supermoderator ] [ Moderator ] :: Detaljnije

Najviše korisnika na forumu ikad bilo je 3466 - dana 01 Jun 2021 17:07

Korisnici koji su trenutno na forumu:
Korisnici trenutno na forumu: _Sale, A.R.Chafee.Jr., Aleksandar Tomić, amaterSRB, babaroga, Boris90, Botovac, CrazyDiablo, dekao, dragon986, Drug pukovnik, Dukelander, gasha, goxin, ikan, Koca Popovic, ladro, Marko Marković, Milan A. Nikolic, milekNS, Milos ZA, Miskohd, ObelixSRB, pacika, pedja.st, sfb, Trpe Grozni, vladom6, vlvl, zdrebac